Rob On Rails

Ruby on Rails insights, news and tips by Rob Zolkos

🔥 Using specific Node JS versions in Github Actions

Sometimes you may want to run your Github Actions using a specific version of NodeJS (eg version 8). This can come in handy if you are dealing with a legacy application and needing to compile a specific version of node-sass for example.

The way to do it is to add the following lines into your workflow file.

- uses: actions/setup-node@v2
  with:
    node-version: "8"